<!DOCTYPE html>
<html lang="en-US" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb#">
<head>
    <meta name="title" content="NEWS784 • St Vincent’s #1 News Source">
<meta name="description" content="A St Vincent and the Grenadines (SVG) online-only News Publication with a Global Perspective.">
<meta name="keywords" content=" News784, 784, 784 news svg, 784 news, st vincent and the grenadines news, Caribbean News, World News, News784, St Vincent News, News On St Vincent and the Grenadines, SVG News, Grenadines News, La Soufriere Updates, La Soufriere News, Kingstown News">
<meta name="robots" content="index, follow">
	
	<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js?client=ca-pub-1248211571860803"
     crossorigin="anonymous"></script>

<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1">
<meta http-equiv="X-UA-Compatible" content="IE=edge">
<meta name="HandheldFriendly" content="true">
<link rel="profile" href="http://gmpg.org/xfn/11">
<link rel="icon" type="image/png" href="https://news784.com/wp-content/uploads/2021/08/Logo-new-7.png" />
<title>Showers and isolated thunderstorms forecast for the Southern Grenadines &#8211; NEWS784</title>
<meta name='robots' content='max-image-preview:large' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="NEWS784 &raquo; Feed" href="https://news784.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="NEWS784 &raquo; Comments Feed" href="https://news784.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="NEWS784 &raquo; Showers and isolated thunderstorms forecast for the Southern Grenadines Comments Feed" href="https://news784.com/2021/08/25/showers-and-isolated-thunderstorms-forecast-for-the-southern-grenadines/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/news784.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.8"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([10084,65039,8205,55357,56613],[10084,65039,8203,55357,56613])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://news784.com/wp-includes/css/dist/block-library/style.min.css?ver=5.8' type='text/css' media='all' />
<style id='wp-block-library-theme-inline-css' type='text/css'>
#start-resizable-editor-section{display:none}.wp-block-audio figcaption{color:#555;font-size:13px;text-align:center}.is-dark-theme .wp-block-audio figcaption{color:hsla(0,0%,100%,.65)}.wp-block-code{font-family:Menlo,Consolas,monaco,monospace;color:#1e1e1e;padding:.8em 1em;border:1px solid #ddd;border-radius:4px}.wp-block-embed figcaption{color:#555;font-size:13px;text-align:center}.is-dark-theme .wp-block-embed figcaption{color:hsla(0,0%,100%,.65)}.blocks-gallery-caption{color:#555;font-size:13px;text-align:center}.is-dark-theme .blocks-gallery-caption{color:hsla(0,0%,100%,.65)}.wp-block-image figcaption{color:#555;font-size:13px;text-align:center}.is-dark-theme .wp-block-image figcaption{color:hsla(0,0%,100%,.65)}.wp-block-pullquote{border-top:4px solid;border-bottom:4px solid;margin-bottom:1.75em;color:currentColor}.wp-block-pullquote__citation,.wp-block-pullquote cite,.wp-block-pullquote footer{color:currentColor;text-transform:uppercase;font-size:.8125em;font-style:normal}.wp-block-quote{border-left:.25em solid;margin:0 0 1.75em;padding-left:1em}.wp-block-quote cite,.wp-block-quote footer{color:currentColor;font-size:.8125em;position:relative;font-style:normal}.wp-block-quote.has-text-align-right{border-left:none;border-right:.25em solid;padding-left:0;padding-right:1em}.wp-block-quote.has-text-align-center{border:none;padding-left:0}.wp-block-quote.is-large,.wp-block-quote.is-style-large{border:none}.wp-block-search .wp-block-search__label{font-weight:700}.wp-block-group.has-background{padding:1.25em 2.375em;margin-top:0;margin-bottom:0}.wp-block-separator{border:none;border-bottom:2px solid;margin-left:auto;margin-right:auto;opacity:.4}.wp-block-separator:not(.is-style-wide):not(.is-style-dots){width:100px}.wp-block-separator.has-background:not(.is-style-dots){border-bottom:none;height:1px}.wp-block-separator.has-background:not(.is-style-wide):not(.is-style-dots){height:2px}.wp-block-table thead{border-bottom:3px solid}.wp-block-table tfoot{border-top:3px solid}.wp-block-table td,.wp-block-table th{padding:.5em;border:1px solid;word-break:normal}.wp-block-table figcaption{color:#555;font-size:13px;text-align:center}.is-dark-theme .wp-block-table figcaption{color:hsla(0,0%,100%,.65)}.wp-block-video figcaption{color:#555;font-size:13px;text-align:center}.is-dark-theme .wp-block-video figcaption{color:hsla(0,0%,100%,.65)}.wp-block-template-part.has-background{padding:1.25em 2.375em;margin-top:0;margin-bottom:0}#end-resizable-editor-section{display:none}
</style>
<link rel='stylesheet' id='fvp-frontend-css'  href='https://news784.com/wp-content/plugins/featured-video-plus/styles/frontend.css?ver=2.3.3' type='text/css' media='all' />
<link rel='stylesheet' id='demo_fonts-css'  href='//fonts.googleapis.com/css?family=Tinos%3Aregular%2Citalic%2C700|Roboto%3Aregular%2Citalic%2C700%26subset%3Dlatin%2C' type='text/css' media='screen' />
<link rel='stylesheet' id='myportal-style-css'  href='https://news784.com/wp-content/themes/myportal/style.css?ver=1.0.1' type='text/css' media='all' />
<link rel='stylesheet' id='genericons-style-css'  href='https://news784.com/wp-content/themes/myportal/genericons/genericons.css?ver=5.8' type='text/css' media='all' />
<link rel='stylesheet' id='responsive-style-css'  href='https://news784.com/wp-content/themes/myportal/responsive.css?ver=20190511' type='text/css' media='all' />
<link rel='stylesheet' id='addtoany-css'  href='https://news784.com/wp-content/plugins/add-to-any/addtoany.min.css?ver=1.15' type='text/css' media='all' />
<script type='text/javascript' src='https://news784.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>
<script type='text/javascript' src='https://news784.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' src='https://news784.com/wp-content/plugins/add-to-any/addtoany.min.js?ver=1.1' id='addtoany-js'></script>
<script type='text/javascript' src='https://news784.com/wp-content/plugins/featured-video-plus/js/jquery.fitvids.min.js?ver=master-2015-08' id='jquery.fitvids-js'></script>
<script type='text/javascript' id='fvp-frontend-js-extra'>
/* <![CDATA[ */
var fvpdata = {"ajaxurl":"https:\/\/news784.com\/wp-admin\/admin-ajax.php","nonce":"46f884a045","fitvids":"1","dynamic":"","overlay":"","opacity":"0.75","color":"b","width":"640"};
/* ]]> */
</script>
<script type='text/javascript' src='https://news784.com/wp-content/plugins/featured-video-plus/js/frontend.min.js?ver=2.3.3' id='fvp-frontend-js'></script>
<link rel="https://api.w.org/" href="https://news784.com/wp-json/" /><link rel="alternate" type="application/json" href="https://news784.com/wp-json/wp/v2/posts/119431" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://news784.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://news784.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.8" />
<link rel="canonical" href="https://news784.com/2021/08/25/showers-and-isolated-thunderstorms-forecast-for-the-southern-grenadines/" />
<link rel='shortlink' href='https://news784.com/?p=119431' />
<link rel="alternate" type="application/json+oembed" href="https://news784.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fnews784.com%2F2021%2F08%2F25%2Fshowers-and-isolated-thunderstorms-forecast-for-the-southern-grenadines%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://news784.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fnews784.com%2F2021%2F08%2F25%2Fshowers-and-isolated-thunderstorms-forecast-for-the-southern-grenadines%2F&#038;format=xml" />

<script data-cfasync="false">
window.a2a_config=window.a2a_config||{};a2a_config.callbacks=[];a2a_config.overlays=[];a2a_config.templates={};
(function(d,s,a,b){a=d.createElement(s);b=d.getElementsByTagName(s)[0];a.async=1;a.src="https://static.addtoany.com/menu/page.js";b.parentNode.insertBefore(a,b);})(document,"script");
</script>

<!-- Begin Custom CSS -->
<style type="text/css" id="demo-custom-css">
.primary{color:#1e73be;font-family:"Tinos","Helvetica Neue",sans-serif;}.secondary{color:#dd3333;}
</style>
<!-- End Custom CSS -->

<!-- START - Open Graph and Twitter Card Tags 3.1.1 -->
 <!-- Facebook Open Graph -->
  <meta property="og:locale" content="en_US"/>
  <meta property="og:site_name" content="NEWS784"/>
  <meta property="og:title" content="Showers and isolated thunderstorms forecast for the Southern Grenadines"/>
  <meta property="og:url" content="https://news784.com/2021/08/25/showers-and-isolated-thunderstorms-forecast-for-the-southern-grenadines/"/>
  <meta property="og:type" content="article"/>
  <meta property="og:description" content="Mostly partly cloudy skies, and hazy conditions will be experienced over the mainland today, with instability lingering over the South.  Moderate showers with a slight chance of isolated thunderstorms are forecast across the Southern Grenadines.
Thursday is forecast to be dry, and around late Thurs"/>
  <meta property="og:image" content="https://news784.com/wp-content/uploads/2021/08/WEATHER-UPDATE-2-OCT.-23-2019-KAF.jpg"/>
  <meta property="og:image:url" content="https://news784.com/wp-content/uploads/2021/08/WEATHER-UPDATE-2-OCT.-23-2019-KAF.jpg"/>
  <meta property="og:image:secure_url" content="https://news784.com/wp-content/uploads/2021/08/WEATHER-UPDATE-2-OCT.-23-2019-KAF.jpg"/>
  <meta property="article:published_time" content="2021-08-25T10:23:47-04:00"/>
  <meta property="article:modified_time" content="2021-08-25T10:23:47-04:00" />
  <meta property="og:updated_time" content="2021-08-25T10:23:47-04:00" />
  <meta property="article:section" content="Weather Update"/>
  <meta property="article:publisher" content="https://www.facebook.com/news784"/>
  <meta property="fb:app_id" content="297722788308778"/>
 <!-- Google+ / Schema.org -->
 <!-- Twitter Cards -->
  <meta name="twitter:title" content="Showers and isolated thunderstorms forecast for the Southern Grenadines"/>
  <meta name="twitter:url" content="https://news784.com/2021/08/25/showers-and-isolated-thunderstorms-forecast-for-the-southern-grenadines/"/>
  <meta name="twitter:description" content="Mostly partly cloudy skies, and hazy conditions will be experienced over the mainland today, with instability lingering over the South.  Moderate showers with a slight chance of isolated thunderstorms are forecast across the Southern Grenadines.
Thursday is forecast to be dry, and around late Thurs"/>
  <meta name="twitter:image" content="https://news784.com/wp-content/uploads/2021/08/WEATHER-UPDATE-2-OCT.-23-2019-KAF.jpg"/>
  <meta name="twitter:card" content="summary_large_image"/>
  <meta name="twitter:site" content="@news_784"/>
 <!-- SEO -->
 <!-- Misc. tags -->
 <!-- is_singular -->
<!-- END - Open Graph and Twitter Card Tags 3.1.1 -->
	

<style type="text/css" media="all">

	body,
	input,
	textarea,
	table,
	.sidebar .widget_ad .widget-title,
	.site-footer .widget_ad .widget-title {
		font-family: "Tinos", "Helvetica Neue", Helvetica, Arial, sans-serif;
	}
	.pagination .page-numbers,
	button,
	.btn,
	input[type="submit"],
	input[type="reset"],
	input[type="button"],
	.comment-form label,
	label,
	h1,h2,h3,h4,h5,h6 {
		font-family: "Roboto", "Helvetica Neue", Helvetica, Arial, sans-serif;
	}

	a,
	a:visited,
	.sf-menu ul li li a:hover,
	.sf-menu li.sfHover li a:hover,
	#primary-menu li.sfHover a,
	#primary-menu li a:hover,	
	#primary-menu li li a:hover,
	#secondary-menu li li a:hover,
	#secondary-menu li a:hover,
	#secondary-menu li.sfHover a,
	.top-right a:hover,
	.home-latest ul li a:hover,
	.breadcrumbs .breadcrumbs-nav a:hover,
	.entry-meta a,
	.comment-reply-title small a:hover,
	.pagination .page-numbers.current,
	.mobile-menu ul li a:hover,
	.pagination .page-numbers:hover,	
	.entry-tags .tag-links a:hover:before,
	.page-content ul li:before,
	.entry-content ul li:before,
	a:hover,
	.site-title a:hover,
	.entry-title a:hover,
	.entry-related .hentry .entry-title a:hover,
	.sidebar .widget a:hover,
	.sidebar .widget ul li a:hover,	 
	.site-footer .widget a:hover,
	.site-footer .widget ul li a:hover,
	.single .navigation a:hover,
	#site-bottom a:hover,
	.content-block .section-heading h3 a:hover,
	.carousel-content .section-heading a:hover,
	.breadcrumbs ul.sub-categories li a:hover,
	.entry-content a:hover,
	.page-content a:hover,
	.author-box .author-meta .author-name a:hover,
	.entry-content li a:hover,
	.page-content li a:hover,
	.content-grid .hentry a:hover .entry-title,
	.friend-nav li a:hover {
		color: #1e73be;
	}
	.sidebar .widget a,
	.site-footer .widget a,
	.logged-in-as a,
	.edit-link a,
	.entry-content a,
	.entry-content a:visited,
	.page-content a,
	.page-content a:visited,
	.tooltip .left .contact-info h3 {
		color: #dd3333;
	}
	button,
	.btn,
	input[type="submit"],
	input[type="reset"],
	input[type="button"],
	button:hover,
	.btn:hover,
	input[type="reset"]:hover,
	input[type="submit"]:hover,
	input[type="button"]:hover,
	.content-loop .entry-header .entry-category-icon a,
	.entry-tags .tag-links a:hover,
	.widget_tag_cloud .tagcloud a:hover,
	.entry-related .section-title:before,
	.comments-title:before,
	#reply-title:before,
	.breadcrumbs h3:before,	
	.friend h3:before,
	.footer-partners .partner-title:before,
	.sidebar .widget .widget-title:before,
	.bottom-right span.icon-link .text,
	.bottom-right a .text {
		background-color: #1e73be;
	}
	.entry-tags .tag-links a:hover:after,
	.widget_tag_cloud .tagcloud a:hover:after {
		border-left-color: #1e73be;
	}
	.bx-wrapper .bx-pager.bx-default-pager a:hover,
	.bx-wrapper .bx-pager.bx-default-pager a.active,
	.bx-wrapper .bx-pager.bx-default-pager a:focus,
	.single #primary .bx-wrapper .bx-pager.bx-default-pager a:hover,
	.single #primary .bx-wrapper .bx-pager.bx-default-pager a.active,
	.single #primary .bx-wrapper .bx-pager.bx-default-pager a:focus {
		background-color: #ffbe02;
	}
	#secondary-bar,
	.content-block .section-heading h3 {
		border-top-color: #1e73be;
	}
		
		
		
		/* Pagination style */
		.pagination {
			display: block;
		}
	
</style>
</head>

<body class="post-template-default single single-post postid-119431 single-format-standard wp-embed-responsive group-blog">

<div id="page" class="site">

	<header id="masthead" class="site-header clear">

		<div id="primary-bar">

			<div class="container">

			<nav id="primary-nav" class="main-navigation">

				<div class="menu-primary-menu-container"><ul id="primary-menu" class="sf-menu"><li id="menu-item-119075" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-119075"><a href="https://news784.com/about/">About</a></li>
<li id="menu-item-119074" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-119074"><a href="https://news784.com/contact/">Contact</a></li>
<li id="menu-item-119076" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-119076"><a href="https://news784.com/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-119077" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-119077"><a href="https://news784.com/terms-of-use/">Terms Of Use</a></li>
<li id="menu-item-119078" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-119078"><a href="https://news784.com/category/weekly-report-venezuela/">Venezuela Report</a></li>
<li id="menu-item-119446" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-119446"><a href="https://news784.com/category/human-rights-in-the-americas/">Human Rights In The Americas</a></li>
</ul></div>
			</nav><!-- #primary-nav -->	

			<ul class="top-right">	

				
									<li class="current-date">
						August 25th, 2021					</li>
								

				

			</ul><!-- .top-right -->

			</div><!-- .container -->

		</div><!-- #primary-bar -->	

		<div class="site-start clear">

			<div class="container">

			<div class="site-branding">

								
				<div id="logo">
					<span class="helper"></span>
					<a href="https://news784.com/" rel="home">
						<img src="https://news784.com/wp-content/uploads/2021/08/oie_213479PS1iV9RM.png" alt=""/>
					</a>
				</div><!-- #logo -->

				
			</div><!-- .site-branding -->

			
				<div class="header-search">
					<form id="searchform" method="get" action="https://news784.com/">
						<input type="search" name="s" class="search-input" placeholder="Search" autocomplete="off">
						<button type="submit" class="search-submit"><i class="fa fa-search"></i></button>		
					</form>
				</div><!-- .header-search -->

			
			<div class="header-icons">
								<span class="header-twitter">
					<a class="Follow us on Twitter" href="https://twitter.com/news_784"><i class="fa fa-twitter"></i>Follow us</a>
				</span>
								
								
				<span class="header-facebook">
					<a title="Become a fan" href="https://www.facebook.com/news784"><i class="fa fa-facebook"></i>Become a fan</a>
				</span>
													
			</div><!-- .header-icons -->

			<span class="mobile-menu-icon">
				<span class="menu-icon-open"><i class="fa fa-bars"></i>Menu</span>
				<span class="menu-icon-close"><i class="fa fa-close"></i>Menu</span>		
			</span>	
			
			</div><!-- .container -->

		</div><!-- .site-start -->

		<div id="secondary-bar" class="container clear">

			<nav id="secondary-nav" class="secondary-navigation">

				<div class="menu-working-menu-container"><ul id="secondary-menu" class="sf-menu"><li id="menu-item-18" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-18"><a href="https://news784.com">Home</a></li>
<li id="menu-item-119065" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-119065"><a href="https://news784.com/category/local-news/">National</a></li>
<li id="menu-item-119068" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-119068"><a href="https://news784.com/category/press-release/">Press Release</a></li>
<li id="menu-item-119066" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-119066"><a href="https://news784.com/category/caribbean/">Caribbean</a></li>
<li id="menu-item-119067" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-119067"><a href="https://news784.com/category/world/">World</a></li>
<li id="menu-item-119069" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-119069"><a href="https://news784.com/category/storm-central/">Weather</a></li>
<li id="menu-item-119070" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-119070"><a href="https://news784.com/category/la-soufriere-updates/">La Soufriere</a></li>
<li id="menu-item-119071" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-119071"><a href="https://news784.com/category/opinion/">Opinion</a></li>
<li id="menu-item-119073" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-119073"><a href="https://news784.com/category/gks-column/">Gk&#8217;s Column</a></li>
<li id="menu-item-119072" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-119072"><a href="https://news784.com/category/crime/">Crime</a></li>
</ul></div>
			</nav><!-- #secondary-nav -->

		</div><!-- .secondary-bar -->

		<div class="mobile-menu clear">

			<div class="container">

			<div class="menu-left"><div class="menu-primary-menu-container"><ul id="primary-mobile-menu" class=""><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-119075"><a href="https://news784.com/about/">About</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-119074"><a href="https://news784.com/contact/">Contact</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-119076"><a href="https://news784.com/privacy-policy/">Privacy Policy</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-119077"><a href="https://news784.com/terms-of-use/">Terms Of Use</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-119078"><a href="https://news784.com/category/weekly-report-venezuela/">Venezuela Report</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-119446"><a href="https://news784.com/category/human-rights-in-the-americas/">Human Rights In The Americas</a></li>
</ul></div></div><div class="menu-right"><div class="menu-working-menu-container"><ul id="secondary-mobile-menu" class=""><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-18"><a href="https://news784.com">Home</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-119065"><a href="https://news784.com/category/local-news/">National</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-119068"><a href="https://news784.com/category/press-release/">Press Release</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-119066"><a href="https://news784.com/category/caribbean/">Caribbean</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-119067"><a href="https://news784.com/category/world/">World</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-119069"><a href="https://news784.com/category/storm-central/">Weather</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-119070"><a href="https://news784.com/category/la-soufriere-updates/">La Soufriere</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-119071"><a href="https://news784.com/category/opinion/">Opinion</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-119073"><a href="https://news784.com/category/gks-column/">Gk&#8217;s Column</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-119072"><a href="https://news784.com/category/crime/">Crime</a></li>
</ul></div></div>
			</div><!-- .container -->

		</div><!-- .mobile-menu -->	

					
			<span class="search-icon">
				<i class="fa fa-search"></i>
				<i class="fa fa-close"></i>			
			</span>

								

	</header><!-- #masthead -->

	<div class="clear"></div>
	
	<div id="media_image-2" class="widget container header-ad widget_media_image"><img width="1500" height="150" src="https://news784.com/wp-content/uploads/2021/08/VG1.jpg" class="image wp-image-119136  attachment-full size-full" alt="" loading="lazy" style="max-width: 100%; height: auto;" srcset="https://news784.com/wp-content/uploads/2021/08/VG1.jpg 1500w, https://news784.com/wp-content/uploads/2021/08/VG1-300x30.jpg 300w, https://news784.com/wp-content/uploads/2021/08/VG1-1024x102.jpg 1024w, https://news784.com/wp-content/uploads/2021/08/VG1-768x77.jpg 768w" sizes="(max-width: 1500px) 100vw, 1500px" /></div>		
	<div id="content" class="site-content container clear">
		<div class="clear">

	<div id="primary" class="content-area">

		
		<div class="breadcrumbs">
			<span class="breadcrumbs-nav">
				<span class="here">You Are Here</span>
				<a href="https://news784.com">Home</a>
				<span class="post-category"><a href="https://news784.com/category/storm-central/" title="View all posts in Weather Update" >Weather Update</a> </span>
				<span class="has-arrow">Showers and isolated thunderstorms forecast for the Southern Grenadines</span>
			</span>
		</div>
		
		
		<main id="main" class="site-main" >

		
<article id="post-119431" class="post-119431 post type-post status-publish format-standard has-post-thumbnail hentry category-storm-central">
	<header class="entry-header">
	
		<h1 class="entry-title">Showers and isolated thunderstorms forecast for the Southern Grenadines</h1>
		<div class="entry-meta">

	
		<span class="entry-author">
			
			<a href="https://news784.com/author/admin/">

				
				NEWS784
			</a>

		</span><!-- .entry-author -->

	
			
					<span class="sep"> - </span>	
		
		<span class="entry-date">
			25 August 2021 : Updated: 25 August 2021 at 10:23 am</p>
		</span><!-- .entry-date --> 
	

	
	
</div><!-- .entry-meta -->


		
	</header><!-- .entry-header -->

	
	<div class="entry-content">
		<img width="790" height="474" src="https://news784.com/wp-content/uploads/2021/08/WEATHER-UPDATE-2-OCT.-23-2019-KAF-790x474.jpg" class="attachment-single_thumb size-single_thumb wp-post-image" alt="" loading="lazy" srcset="https://news784.com/wp-content/uploads/2021/08/WEATHER-UPDATE-2-OCT.-23-2019-KAF-790x474.jpg 790w, https://news784.com/wp-content/uploads/2021/08/WEATHER-UPDATE-2-OCT.-23-2019-KAF-300x180.jpg 300w" sizes="(max-width: 790px) 100vw, 790px" />	
		<p style="font-weight: 400; text-align: justify;">Mostly partly cloudy skies, and hazy conditions will be experienced over the mainland today, with instability lingering over the South.  Moderate showers with a slight chance of isolated thunderstorms are forecast across the Southern Grenadines.</p>
<p style="font-weight: 400; text-align: justify;">Thursday is forecast to be dry, and around late Thursday, a tropical wave will pass over the islands. A few scattered showers are likely from this wave. Mostly fair conditions are forecast for Friday.</p>
<p style="font-weight: 400; text-align: justify;">Generally, a moderate (25km/h-35km/h) easterly wind flow will move across the islands, decreasing in speed by Thursday becoming east northeasterly.</p>
<p style="font-weight: 400; text-align: justify;">Sea conditions will be slight to moderate in open waters, with swells peaking at 1.0m on the western coasts and 2.0m on the eastern coasts. In addition, varying concentrations of Saharan haze intrusion will linger across the island during the next few days.</p>
<div class="addtoany_share_save_container addtoany_content addtoany_content_bottom"><div class="a2a_kit a2a_kit_size_30 addtoany_list" data-a2a-url="https://news784.com/2021/08/25/showers-and-isolated-thunderstorms-forecast-for-the-southern-grenadines/" data-a2a-title="Showers and isolated thunderstorms forecast for the Southern Grenadines"><a class="a2a_button_facebook" href="https://www.addtoany.com/add_to/facebook?linkurl=https%3A%2F%2Fnews784.com%2F2021%2F08%2F25%2Fshowers-and-isolated-thunderstorms-forecast-for-the-southern-grenadines%2F&amp;linkname=Showers%20and%20isolated%20thunderstorms%20forecast%20for%20the%20Southern%20Grenadines" title="Facebook" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_twitter" href="https://www.addtoany.com/add_to/twitter?linkurl=https%3A%2F%2Fnews784.com%2F2021%2F08%2F25%2Fshowers-and-isolated-thunderstorms-forecast-for-the-southern-grenadines%2F&amp;linkname=Showers%20and%20isolated%20thunderstorms%20forecast%20for%20the%20Southern%20Grenadines" title="Twitter" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_whatsapp" href="https://www.addtoany.com/add_to/whatsapp?linkurl=https%3A%2F%2Fnews784.com%2F2021%2F08%2F25%2Fshowers-and-isolated-thunderstorms-forecast-for-the-southern-grenadines%2F&amp;linkname=Showers%20and%20isolated%20thunderstorms%20forecast%20for%20the%20Southern%20Grenadines" title="WhatsApp" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_email" href="https://www.addtoany.com/add_to/email?linkurl=https%3A%2F%2Fnews784.com%2F2021%2F08%2F25%2Fshowers-and-isolated-thunderstorms-forecast-for-the-southern-grenadines%2F&amp;linkname=Showers%20and%20isolated%20thunderstorms%20forecast%20for%20the%20Southern%20Grenadines" title="Email" rel="nofollow noopener" target="_blank"></a></div></div>	</div><!-- .entry-content -->

	<div class="entry-footer clear">
		<div class="entry-tags">

							
					</div><!-- .entry-tags -->

	
				
	</div><!-- .entry-footer -->



</article><!-- #post-## -->



<div id="comments" class="comments-area">
	
	
		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2021/08/25/showers-and-isolated-thunderstorms-forecast-for-the-southern-grenadines/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://news784.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="email" value="" size="30" maxlength="100" aria-describedby="email-notes" required='required' /></p>
<p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /> <label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='119431' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="a962bdcc97" /></p><input type="hidden" id="ak_js" name="ak_js" value="168"/><textarea name="ak_hp_textarea" cols="45" rows="8" maxlength="100" style="display: none !important;"></textarea></form>	</div><!-- #respond -->
	
</div><!-- #comments -->
		</main><!-- #main -->
	</div><!-- #primary -->


<aside id="secondary" class="widget-area sidebar">


	<div id="media_image-5" class="widget widget_media_image"><h2 class="widget-title"><span>Advertisement</span></h2><img width="500" height="500" src="https://news784.com/wp-content/uploads/2021/08/DiamondWoods784.jpeg" class="image wp-image-119137  attachment-full size-full" alt="" loading="lazy" style="max-width: 100%; height: auto;" title="Advertisement" srcset="https://news784.com/wp-content/uploads/2021/08/DiamondWoods784.jpeg 500w, https://news784.com/wp-content/uploads/2021/08/DiamondWoods784-300x300.jpeg 300w, https://news784.com/wp-content/uploads/2021/08/DiamondWoods784-150x150.jpeg 150w" sizes="(max-width: 500px) 100vw, 500px" /></div><div id="media_image-6" class="widget widget_media_image"><h2 class="widget-title"><span>Advertisement</span></h2><img width="500" height="500" src="https://news784.com/wp-content/uploads/2021/08/239551329_4289322451156597_1140335679748981568_n.jpg" class="image wp-image-119138  attachment-full size-full" alt="" loading="lazy" style="max-width: 100%; height: auto;" srcset="https://news784.com/wp-content/uploads/2021/08/239551329_4289322451156597_1140335679748981568_n.jpg 500w, https://news784.com/wp-content/uploads/2021/08/239551329_4289322451156597_1140335679748981568_n-300x300.jpg 300w, https://news784.com/wp-content/uploads/2021/08/239551329_4289322451156597_1140335679748981568_n-150x150.jpg 150w" sizes="(max-width: 500px) 100vw, 500px" /></div>	

</aside><!-- #secondary -->

		</div><!-- .clear -->

	</div><!-- #content .site-content -->
	
	<footer id="colophon" class="site-footer container">

		
		
		<div class="clear"></div>

				

		<div id="site-bottom" class="clear">

				

			<div class="site-info">

				© 2021 NEWS784. All rights reserved.
			</div><!-- .site-info -->
			
		</div><!-- #site-bottom -->
							
	</footer><!-- #colophon -->

</div><!-- #page -->

<div class="bottom-right">

	
	
		<div id="back-top">
		<a href="#top" title="Back to top"><span class="icon"><i class="fa fa-chevron-up"></i></span></a>
	</div>
	</div><!-- .bottom-right -->

<script type="application/ld+json" class="bpfwp-ld-json-data">[{"@context":"http:\/\/schema.org","@type":"Article","author":{"name":"NEWS784"},"datePublished":"25 August 2021","dateModified":"25 August 2021","headline":"Showers and isolated thunderstorms forecast for the Southern Grenadines","image":"https:\/\/news784.com\/wp-content\/uploads\/2021\/08\/WEATHER-UPDATE-2-OCT.-23-2019-KAF.jpg","description":"Mostly partly cloudy skies, and hazy conditions will be experienced over the mainland today, with instability lingering over the South.\u00a0 Moderate showers with a slight chance of isolated thunderstorms are forecast across the Southern Grenadines. Thursday is forecast to be&hellip;","publisher":{"name":"","logo":{"url":"","width":"","height":""}}}]</script><script type='text/javascript' src='https://news784.com/wp-content/themes/myportal/assets/js/superfish.js?ver=5.8' id='superfish-js'></script>
<script type='text/javascript' src='https://news784.com/wp-content/themes/myportal/assets/js/modernizr.min.js?ver=5.8' id='modernizr-js'></script>
<script type='text/javascript' src='https://news784.com/wp-content/themes/myportal/assets/js/html5.js?ver=5.8' id='html5-js'></script>
<script type='text/javascript' src='https://news784.com/wp-content/themes/myportal/assets/js/jquery.bxslider.min.js?ver=5.8' id='bxslider-js'></script>
<script type='text/javascript' src='https://news784.com/wp-content/themes/myportal/assets/js/jquery.custom.js?ver=20190505' id='custom-js'></script>
<script type='text/javascript' src='https://news784.com/wp-includes/js/comment-reply.min.js?ver=5.8' id='comment-reply-js'></script>
<script type='text/javascript' src='https://news784.com/wp-content/plugins/mystickysidebar/js/detectmobilebrowser.js?ver=1.2.3' id='detectmobilebrowser-js'></script>
<script type='text/javascript' id='mystickysidebar-js-extra'>
/* <![CDATA[ */
var mystickyside_name = {"mystickyside_string":"#secondary","mystickyside_content_string":"","mystickyside_margin_top_string":"90","mystickyside_margin_bot_string":"0","mystickyside_update_sidebar_height_string":"false","mystickyside_min_width_string":"795","device_desktop":"1","device_mobile":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://news784.com/wp-content/plugins/mystickysidebar/js/theia-sticky-sidebar.js?ver=1.2.3' id='mystickysidebar-js'></script>
<script type='text/javascript' src='https://news784.com/wp-includes/js/wp-embed.min.js?ver=5.8' id='wp-embed-js'></script>
<script defer type='text/javascript' src='https://news784.com/wp-content/plugins/akismet/_inc/form.js?ver=4.1.11' id='akismet-form-js'></script>

</body>
<!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-185874443-2"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-185874443-2');
</script>

</html>
